Text Services

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Scheduled maintenance
Complete·Under maintenance·Mar 28, 7:00 AM - 8:30 AM
Sat, Mar 28, 2026, 08:30 AM
(1 month ago)
·
Affected components
Support on text.com
Updates

Complete

Maintenance has completed

Sat, Mar 28, 2026, 08:30 AM

In progress

We’re extending the ongoing maintenance by an additional 30 minutes to ensure everything is completed properly and performing as expected.

We appreciate your patience and understanding, and we’ll notify you as soon as everything is back to normal.

Sat, Mar 28, 2026, 07:52 AM(37 minutes earlier)

In progress

Maintenance has started

Sat, Mar 28, 2026, 07:00 AM(52 minutes earlier)

Scheduled

We will be performing platform maintenance on Saturday, 28th March, from 8:00 AM to 9:00 AM CET. During this one-hour maintenance window, contact with our support team via the chat widget will be temporarily unavailable while we improve our systems.

We appreciate your understanding and apologize for any inconvenience this may cause.

Fri, Mar 20, 2026, 09:21 AM(1 week earlier)