Performance degradation of our services
Resolved·Degraded performance

We see that the issue within our cloud provider’s infrastructure has been mitigated, and we can confirm that the infrastructure is healthy, and we are not seeing further errors. Throughout the degradation, our platform was able to maintain service continuity. We appreciate your patience and understanding while we coordinated our efforts with the cloud provider’s engineers to address the issue.

Wed, Jan 21, 2026, 01:42 AM
(1 week ago)
·
Affected components
Text App
API
Subprocessors' service
Updates

Resolved

We see that the issue within our cloud provider’s infrastructure has been mitigated, and we can confirm that the infrastructure is healthy, and we are not seeing further errors. Throughout the degradation, our platform was able to maintain service continuity. We appreciate your patience and understanding while we coordinated our efforts with the cloud provider’s engineers to address the issue.

Wed, Jan 21, 2026, 01:42 AM

Monitoring

After discussing the issue with our admins, the cloud provider engineers are still working on the case and investigating further. Currently, we are not seeing any further issues, but we are still monitoring the situation.

Wed, Jan 21, 2026, 01:28 AM(14 minutes earlier)

Investigating

We are still investigating the situation and working with our cloud provider engineers to implement the fix.

Wed, Jan 21, 2026, 12:47 AM(40 minutes earlier)

Investigating

We have received a communication from the cloud provider's engineers stating that they are reviewing our case.

Wed, Jan 21, 2026, 12:07 AM(40 minutes earlier)

Investigating

We noticed a performance degradation in our services related to issues with our cloud provider. We're currently investigating this issue.

Tue, Jan 20, 2026, 11:26 PM(40 minutes earlier)